Interesting update...
If I have the device send to an account on the SM server... it works.
But, if the SM server is relaying to an outside box it fails.
As mentioned above the IP is whitelisted so I can't explain why that is the case.
We also found that we can catch the messages using an event and then forward them on.
But, we cannot use content filtering to forward the message.
Get the same error I documented in my initial post.
NOT RESOLVED... but we have figured out the above work-around.