Hi Guys
I'm seeing this issue with Gateways in SM 16.3.6989 and SM 7957.
I'm also seeing this issue with any delivery that can't find MX and the SM tries to deliver to the A record which in some situations is the completely wrong email server.
Smartermail should have a setting to turn off Delivery to A record and bounce the email.
Below is a similar issue with Gateway Settings using the same deliver to A record.
When starting delivery I see this in the logs
[2022.03.02] 10:51:31 [67687] Failed to connect to the recipient's mail server. No MX records were found for the 'smtp.mailchannels.net' domain. Failing over to A records.
Delivery for this email is using the Gateway for mailchannels.
This looks like Smarter mail is trying to look up MX using the Gateway connection server URL setting. This should not work like this.
This appears to be an issue for a long time and causes bounce problems and delivery sometimes to the wrong servers.
J. Sebastian Lee Service2Client LLC 6333 E Mockingbird Ste 147 Dallas, TX 75214 - 877.251.3273